Members
Stats
  • Total Posts: 28531
  • Total Topics: 8240
  • Online Today: 940
  • Online Ever: 51419
  • (01. January 2010., 10:27:49)












Author Topic: [solved] windows 7 display language all set to English, still upgrade fails  (Read 969 times)

0 Members and 1 Guest are viewing this topic.

devnullius

  • SCF VIP Member
  • *****
  • Posts: 3507
  • KARMA: 152
  • Gender: Female
    • SCForum.info
change MUI language pack in Windows 7 home and professional

I am upgrading a windows xp machine to vista to windows 7 (Ultimate, which offers language packs by default) to windows 8 to windows 8.1

Windows XP / Vista / 7 SP0 are all Dutch. I wanted to do the repair upgrade for Windows 7 to 8 with an English warez cd I had. This failed: You can’t do a typical upgrade using an installation disc that’s different from the language installed on your computer.

This was despite me having set all system locals, user accounts, log on screens etc to English with Control Panel's Set Display Language. Even Windows Update was English already....!

The sollution was a bit tricky for me; once I downloaded my appropriate language pack (http://www.wincert.net/tips/microsoft-windows/windows-7/2086-how-to-use-another-language-pack-on-windows-7-home-premium-and-professional or http://www.froggie.sk/7lp32rtm.html). Once I start the executable, lp.cab gets automatically extracted and removed. So I just had to right-click it really fast and copied it to the desktop. You might be able to get the file with 7-zip too (I did not test).

After that, I copied lp.cab to c:\ (no risks with C:, but you are free to chose a custom folder).

Then, from: http://superuser.com/questions/331779/how-can-i-change-the-language-of-windows-7-to-english or https://mark.ossdl.de/2009/08/change-mui-language-pack-in-windows-7-home-and-professional/) I ddi the following:

Quote
you will have to get the appropriate “lp.cab”, i.e. from the Language Pack DVD. Then, type this in a command prompt as Administrator (change path and language code appropriately):

dism /online /add-package /packagepath:D:\langpacks\en-us\lp.cab

bcdedit /set {current} locale en-US

bcdboot %WinDir% /l en-US

After that, remove the registry folder HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MUI\UILanguages\de-DE.

Reboot

If you get this error: An error occured trying to open d:\en-us\langpacks\lp.cab Error:0×80070003. The System cannot find the path specified

copy the lp.cab to C:\ (the root directory) and run dism from there.

The command line shell must be run as Administrator.

Rebooted the system? Good! Happy upgrading :)

Devvie

PS: usually just setting the display languages all to English does the trick. This time, it did not :)
More information about bitcoin, altcoin & crypto in general? GO TO  j.gs/7385484/btc

Cuisvis hominis est errare, nullius nisi insipientis in errore persevare... So why not get the real SCForum employees to help YOUR troubled computer!!! SCF Remote PC Assist http://goo.gl/n1ONa9

Samker's Computer Forum - SCforum.info





 

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Name: Email:
Verification:
Type the letters shown in the picture
Listen to the letters / Request another image
Type the letters shown in the picture:
Second Anti-Bot trap, type or simply copy-paste below (only the red letters):www.scforum.info:

Enter your email address to receive daily email with 'SCforum.info - Samker's Computer Forum' newest content:

Terms of Use | Privacy Policy | Advertising